NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🛡️
Not in CISA KEV
HIGH severity

CVE-2023-44443 — gimp

HIGH

CVE-2023-44443 is a high-severity (CVSS 7.8) CWE-190 vulnerability. EPSS puts its 30-day exploitation probability at 93.6% (100th percentile). A fix is available — see the affected versions and patch details below.

GIMP PSP File Parsing Integer Overflow Remote Code Execution Vulnerability

Published
Updated
Affected
1 product
Patched
See advisory
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-44443.

EPSS Exploitation Probability

via FIRST.org ↗
93.6%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
54.8%69.9%84.9%100.0%63.8%93.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Description

GIMP PSP File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of PSP files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before writing to memory. An attacker can leverage this vulnerability to execute code in the context of the current process. . Was ZDI-CAN-22096.

Affected Products

1 product · 1 configurations
Application
gimpgimp
< 2.10.36
range

Detection & mitigation playbook

Vulnerability
  1. Detect

    Identify every host running the affected component and compare the installed build against the fixed version below — for source-built or distro-packaged software the version string, not a lockfile, is the source of truth (`dpkg -l`, `rpm -q`, or the binary's own `--version`).

  2. Fix

    Upgrade the affected component to the fixed release for CVE-2023-44443, or apply your distribution's backported patch — distro builds are often patched at an older version number, so check your vendor's advisory rather than the upstream version alone.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat Enterprise Linux 7 and 8 is not affected by this issue as the we don't shipped the affected version.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2023-44443 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 8gimp:2.8-8100020250110133707.4c9c024fRHSA-2025:0746
Red Hat Enterprise Linux 9gimp-2:2.99.8-4.el9_3RHSA-2024:0675
Red Hat Enterprise Linux 9gimp-2:2.99.8-4.el9_5RHSA-2025:3617
Red Hat Enterprise Linux 9gimp-2:2.99.8-4.el9_6RHSA-2025:7417
Red Hat Enterprise Linux 9.0 Extended Update Supportgimp-2:2.99.8-3.el9_0RHSA-2024:0716
Red Hat Enterprise Linux 9.2 Extended Update Supportgimp-2:2.99.8-4.el9_2RHSA-2024:0702
Red Hat Enterprise Linux 9.4 Extended Update Supportgimp-2:2.99.8-4.el9_4RHSA-2025:3629

Frequently Asked Questions

GIMP PSP File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of PSP files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before writing to memory. An attacker can leverage this vulnerability to execute code in the context of the curre
O3 Security · Impact-Aware SCA

Is CVE-2023-44443 in your dependencies?

Find it across your dependency tree, including transitive dependencies.

CVE-2023-44443: gimp RCE (High 7.8)