NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2023-43472 — mlflow

HIGH

CVE-2023-43472 is a high-severity (CVSS 7.5) vulnerability in mlflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mlflow — see the affected versions and patch details below.

Information exposure in MLflow

Also known asBIT-mlflow-2023-43472GHSA-wqxf-447m-6f5fPYSEC-2026-1661
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
36.6%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
25.2%45.4%65.6%85.8%74.4%36.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mlflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue in MLFlow versions 2.8.1 and before allows a remote attacker to obtain sensitive information via a crafted request to REST API.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImlflowall versions2.9.0pip install --upgrade 'mlflow==2.9.0'

Affected Products

1 product · 1 configurations
Application
mlflowlfprojects
≤ 2.8.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mlflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mlflow to 2.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-43472 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2023-43472

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-43472 -u https://target
Template
MLFlow < 2.8.1 - Sensitive Information Disclosure
Severity
high
Impact
An attacker can access sensitive information stored in MLFlow.
Remediation
Upgrade MLFlow to a version that has patched CVE-2023-43472.

Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

An issue in MLFlow versions 2.8.1 and before allows a remote attacker to obtain sensitive information via a crafted request to REST API.
O3 Security · Impact-Aware SCA

Is CVE-2023-43472 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-43472: mlflow Info Disclosure — Fixed in 2.9.0