CVE-2023-42444 is a high-severity (CVSS 8.6) CWE-248 vulnerability in phonenumber. A fix is available for phonenumber — see the affected versions and patch details below.
phonenumber panics on parsing crafted RF3966 inputs
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-42444.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phonenumber🦀phonenumberReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
phonenumber is a library for parsing, formatting and validating international phone numbers. Prior to versions 0.3.3+8.13.9 and 0.2.5+8.11.3, the phonenumber parsing code may panic due to a panic-guarded out-of-bounds access on the phonenumber string. In a typical deployment of rust-phonenumber, this may get triggered by feeding a maliciously crafted phonenumber over the network, specifically the string .;phone-context=. Versions 0.3.3+8.13.9 and 0.2.5+8.11.3 contain a patch for this issue. There are no known workarounds.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | phonenumber | all versions | 0.2.5cargo update -p phonenumber --precise 0.2.5 |
| 🦀crates.io | phonenumber | ≥ 0.3.0&&< 0.3.3 | 0.3.3cargo update -p phonenumber --precise 0.3.3 |
Affected Products
phonenumberwhisperfishDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phonenumber, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phonenumber to 0.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-42444 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Frequently Asked Questions
Is CVE-2023-42444 in your dependencies?
Find it across crates.io, including transitive dependencies.