CVE-2023-41900 is a low-severity (CVSS 3.5) CWE-1390 vulnerability in org.eclipse.jetty:jetty-openid. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.eclipse.jetty:jetty-openid — see the affected versions and patch details below.
Jetty's OpenId Revoked authentication allows one request
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-41900.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-openid☕org.eclipse.jetty:jetty-openid☕org.eclipse.jetty:jetty-openidReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
If a Jetty OpenIdAuthenticator uses the optional nested LoginService, and that LoginService decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated.
So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the LoginService.
Impact
This impacts usages of the jetty-openid which have configured a nested LoginService and where that LoginService will is capable of rejecting previously authenticated users.
Original Report
working on a custom OpenIdAuthenticator, I discovered the following:
In the case where the LoginService does return that the authentication has been revoked (from the validate() call on line 463), the OpenIdAuthenticator removes the authentication from the session; however the current request still proceeds as if authenticated, since it falls through to "return authentication" on line 505.
This is fixed by moving the line 505 (and associated debug log) inside the else block that ends on line 502, instead of outside it. Then the revocation case will run through to line 517 and will trigger a new OpenId authentication which I think is correct.
I think this revocation can only occur if you do attach a separate LoginService to the OpenIdLoginService, but in that case the revoked authentication will still let the next request through (and possibly more than one if they are very close to simultaneous).
Technically I think this is a security vulnerability, if a very minor one, so I'm sending this off-list.
Patched Versions
Fixed in Jetty Versions:
- 9.4.52 - fixed in PR https://github.com/eclipse/jetty.project/pull/9660
- 10.0.16 - fixed in PR https://github.com/eclipse/jetty.project/pull/9528
- 11.0.16 - fixed in PR https://github.com/eclipse/jetty.project/pull/9528
- 12.0.0 - not impacted (already has fix)
Workaround
Upgrade your version of Jetty.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-openid | ≥ 9.4.21&&< 9.4.52.v20230823 | 9.4.52.v20230823org.eclipse.jetty:jetty-openid:9.4.52.v20230823 |
| ☕Maven | org.eclipse.jetty:jetty-openid | ≥ 10.0.0&&< 10.0.16 | 10.0.16org.eclipse.jetty:jetty-openid:10.0.16 |
| ☕Maven | org.eclipse.jetty:jetty-openid | ≥ 11.0.0&&< 11.0.16 | 11.0.16org.eclipse.jetty:jetty-openid:11.0.16 |
Affected Products
debian linuxdebianjettyeclipseResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-openid, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-openid to 9.4.52.v20230823 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-41900 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.12.1 | jetty | RHSA-2023:7247 |
Frequently Asked Questions
Is CVE-2023-41900 in your dependencies?
Find it across Maven, including transitive dependencies.