CVE-2023-41886 is a high-severity (CVSS 7.5) SQL Injection vulnerability in org.openrefine:database. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.openrefine:database — see the affected versions and patch details below.
OpenRefine vulnerable to arbitrary file read in project import with mysql jdbc url attack
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-41886.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.openrefine:databaseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
An arbitrary file read vulnerability allows any unauthenticated user to read the file on the server._
Details
Hi,Team, i find openrefine support to import data from database,When use mysql jdbc to connect to database,It is vulnerable to jdbc url attacks,for example,unauthenticated attacker can read the file on the server. There are some differences in utilization depending on the version of the mysql-connector dependency on the server side.
- mysql-connector-java version > 8.14
The default value of
allowLoadLocalInfileon the server side is false in this case.We need to manually set this value to true in the connection string.
Since the way to get the databaseurl incom/google/refine/extension/database/mysql/MySQLConnectionManager.javais to splice the individual configurations directly, we can set theallowLoadLocalInfileparameter after the other parameters(for example thedatabaseNameparameter ).


- mysql-connector-java version <= 8.14
The default value of
allowLoadLocalInfileon the server side is true in this case.so wo don't need do anything,Just connect to our malicious server.
PoC
env:
centos 7
openrefine 3.7.4
jdk11
mysql-connector-java version 8.30.0
you can use the tool https://github.com/4ra1n/mysql-fake-server to running a malicious mysql server.

for example,to read the /etc/passwd file.
set the username to base64ZmlsZXJlYWRfL2V0Yy9wYXNzd2Q= and Database name to test?allowLoadLocalInfile=true# (for mysql-connector-java version <= 8.14,just setting the database name normally) and test to connect your malicious mysql server.
you can get the file in your fake-server-files directory.

Impact
An arbitrary file read vulnerability allows any unauthenticated user to read the file on the server._
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.openrefine:database | all versions | 3.7.5org.openrefine:database:3.7.5 |
Affected Products
openrefineopenrefineResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.openrefine:database, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.openrefine:database to 3.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-41886 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2023-41886 in your dependencies?
Find it across Maven, including transitive dependencies.