CVE-2023-41419 is a critical-severity (CVSS 9.8) vulnerability in gevent. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for gevent — see the affected versions and patch details below.
Gevent allows remote attacker to escalate privileges
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
geventReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue in Gevent before version 23.9.0 allows a remote attacker to escalate privileges via a crafted script to the WSGIServer component.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | gevent | all versions | 23.9.0pip install --upgrade 'gevent==23.9.0' |
Affected Products
geventgeventResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gevent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update gevent to 23.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-41419 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2023-41419 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | python-gevent-0:1.2.2-5.el8_10 | RHSA-2024:8834 |
| Red Hat Enterprise Linux 8.2 Advanced Update Support | python-gevent-0:1.2.2-5.el8_2 | RHSA-2024:7785 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | python-gevent-0:1.2.2-5.el8_4 | RHSA-2024:8105 |
| Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support | python-gevent-0:1.2.2-5.el8_6 | RHSA-2024:7421 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | python-gevent-0:1.2.2-5.el8_8 | RHSA-2024:8102 |
| Red Hat OpenStack Platform 17.1 for RHEL 9 | python-gevent-0:21.1.2-2.el9ost | RHSA-2023:7438 |
Frequently Asked Questions
Is CVE-2023-41419 in your dependencies?
Find it across PyPI, including transitive dependencies.