CVE-2023-41339 — gs-wms
HIGHCVE-2023-41339 is a high-severity (CVSS 8.6) Server-Side Request Forgery (SSRF) vulnerability in org.geoserver:gs-wms. A fix is available for org.geoserver:gs-wms — see the affected versions and patch details below.
Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-41339.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.geoserver:gs-wms☕org.geoserver:gs-wms☕org.geoserver.web:gs-web-app☕org.geoserver.web:gs-web-appReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
The WMS specification defines an sld=<url> parameter for GetMap, GetLegendGraphic and GetFeatureInfo operations for user supplied "dynamic styling". Enabling the use of dynamic styles, without also configuring URL checks, provides the opportunity for Service Side Request Forgery.
It is possible to use this for "Blind SSRF" on the WMS endpoint to steal NetNTLMv2 hashes via file requests to malicious servers.
Details
This vulnerability requires:
- WMS Settings dynamic styling being enabled
- Security URL checks to be disabled, or to be enabled and allowing
file:\\*access
Impact
This vulnerability can be used to steal user NetNTLMv2 hashes which could be relayed or cracked externally to gain further access.
Mitigation
The ability to reference an external URL location is defined by the WMS standard GetMap, GetFeatureInfo and GetLegendGraphic operations. These operations are defined by an Industry and International standard and cannot be redefined by the GeoServer application in isolation.
To disable dynamic styling on GeoServer 2.10.3 and GeoServer 2.11.1:
- Navigate to Services > WMS Settings page
- Locate Dynamic styling heading
- Select the Disable usage of SLD and SLD_BODY parameters in GET requests and user styles in POST checkbox.
Resolution
To allow dynamic styling safely on GeoServer 2.22.5 and GeoServer 2.23.2:
- Navigate to Security > URL Checks
- Enable URL Checks are enabled setting
- Check the user manual for examples of how to trust specific locations:
^https://styles\.server\.net/cartography/.*$ - Enable dynamic styling on the Services > WMS Settings page, deselect the Disable usage of SLD and SLD_BODY parameters in GET requests and user styles in POST checkbox.
Use of dynamic styling safely is on by default in GeoServer 2.24.0.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.geoserver:gs-wms | all versions | 2.22.5org.geoserver:gs-wms:2.22.5 |
| ☕Maven | org.geoserver:gs-wms | ≥ 2.23.0&&< 2.23.2 | 2.23.2org.geoserver:gs-wms:2.23.2 |
| ☕Maven | org.geoserver.web:gs-web-app | all versions | 2.22.5org.geoserver.web:gs-web-app:2.22.5 |
| ☕Maven | org.geoserver.web:gs-web-app | ≥ 2.23.0&&< 2.23.2 | 2.23.2org.geoserver.web:gs-web-app:2.23.2 |
Affected Products
geoserverosgeoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.geoserver:gs-wms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.geoserver:gs-wms to 2.22.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-41339 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2023-41339 in your dependencies?
Find it across Maven, including transitive dependencies.