CVE-2023-40577 — alertmanager
HIGHCVE-2023-40577 is a high-severity (CVSS 7.5) Cross-site Scripting (XSS) vulnerability in github.com/prometheus/alertmanager. A fix is available for github.com/prometheus/alertmanager — see the affected versions and patch details below.
Alertmanager UI is vulnerable to stored XSS via the /api/v1/alerts endpoint
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-40577.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/prometheus/alertmanagerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An attacker with the permission to perform POST requests on the /api/v1/alerts endpoint could be able to execute arbitrary JavaScript code on the users of Prometheus Alertmanager.
Patches
Users can upgrade to Alertmanager v0.2.51.
Workarounds
Users can setup a reverse proxy in front of the Alertmanager web server to forbid access to the /api/v1/alerts endpoint.
References
N/A
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/prometheus/alertmanager | all versions | 0.25.1go get github.com/prometheus/alertmanager@v0.25.1 |
Affected Products
debian linuxdebianalertmanagerprometheusDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/prometheus/alertmanager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/prometheus/alertmanager to 0.25.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-40577 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability affects Prometheus Alertmanager v0.25.0, which is not shipped in Red Hat OpenShift container platform, therefore, this is marked as Not affected.
Users can setup a reverse proxy in front of the Alertmanager web server to forbid access to the /api/v1/alerts endpoint.Source: Red Hat security advisory for CVE-2023-40577 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.15 | openshift4/ose-prometheus-alertmanager:v4.15.0-202401290854.p0.g870ade5.assembly.stream | RHSA-2023:7198 |
Frequently Asked Questions
Is CVE-2023-40577 in your dependencies?
Find it across Go, including transitive dependencies.