NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2023-39631 — langchain

CRITICALFix: langchain-ai/langchain#11302

CVE-2023-39631 is a critical-severity (CVSS 9.8) Code Injection vulnerability in langchain. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for langchain — see the affected versions and patch details below.

Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library

Also known asGHSA-f73w-4m7g-ch9xPYSEC-2023-162PYSEC-2023-163
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-39631.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.82%1.30%1.78%2.25%1.6%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍langchain🐍numexpr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library.

Patches: Released in v.0.0.308. numexpr dependency is optional for langchain.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIlangchainall versions0.0.308pip install --upgrade 'langchain==0.0.308'
🐍PyPInumexprall versions2.8.5pip install --upgrade 'numexpr==2.8.5'

Affected Products

1 product · 1 configurations
Application
langchainlangchain
1 version
0.0.245
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for langchain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update langchain to 0.0.308 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-39631 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library. Patches: Released in v.0.0.308. numexpr dependency is optional for langchain.
O3 Security · Impact-Aware SCA

Is CVE-2023-39631 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-39631: langchain RCE — Fixed in 0.0.308