NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2023-38670 — paddlepaddle

HIGHFix: PaddlePaddle/Paddle@ed96bae

CVE-2023-38670 is a high-severity (CVSS 7.5) NULL Pointer Dereference vulnerability in paddlepaddle. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for paddlepaddle — see the affected versions and patch details below.

Null pointer dereference in PaddlePaddle

Also known asGHSA-rr46-m366-gm44PYSEC-2023-123
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-38670.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.39%0.77%1.16%0.2%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍paddlepaddle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Null pointer dereference in paddle.flip in PaddlePaddle before 2.5.0. This resulted in a runtime crash and denial of service.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpaddlepaddleall versions2.5.0pip install --upgrade 'paddlepaddle==2.5.0'

Affected Products

1 product · 1 configurations
Application
paddlepaddlepaddlepaddle
< 2.5.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for paddlepaddle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update paddlepaddle to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-38670 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Null pointer dereference in paddle.flip in PaddlePaddle before 2.5.0. This resulted in a runtime crash and denial of service.
O3 Security · Impact-Aware SCA

Is CVE-2023-38670 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-38670: paddlepaddle DoS — Fixed in 2.5.0