NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-38435 — org.apache.felix.healthch…

MEDIUMFix: apache/felix-dev@c4e6752

CVE-2023-38435 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.felix:org.apache.felix.healthcheck.webconsoleplugin. A fix is available for org.apache.felix:org.apache.felix.healthcheck.webconsoleplugin — see the affected versions and patch details below.

Cross-site Scripting in healthcheck webconsole plugin

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.85%1.48%2.12%2.75%1.4%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.felix:org.apache.felix.healthcheck.webconsoleplugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability in Apache Felix Healthcheck Webconsole Plugin version 2.0.2 and prior may allow an attacker to perform a reflected cross-site scripting (XSS) attack.

Upgrade to Apache Felix Healthcheck Webconsole Plugin 2.1.0 or higher.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.felix:org.apache.felix.healthcheck.webconsolepluginall versions2.1.0org.apache.felix:org.apache.felix.healthcheck.webconsoleplugin:2.1.0

Affected Products

1 product · 1 configurations
Application
felix health check webconsole pluginapache
< 2.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.felix:org.apache.felix.healthcheck.webconsoleplugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.felix:org.apache.felix.healthcheck.webconsoleplugin to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-38435 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability in Apache Felix Healthcheck Webconsole Plugin version 2.0.2 and prior may allow an attacker to perform a reflected cross-site scripting (XSS) attack. Upgrade to Apache Felix Healthcheck Webconsole Plugin 2.1.0 or higher.
O3 Security · Impact-Aware SCA

Is CVE-2023-38435 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-38435: org.apache.felix XSS — Fixed in 2.1.0