NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2023-3765 — mlflow

CRITICALFix: mlflow/mlflow@6dde937

CVE-2023-3765 is a critical-severity (CVSS 10) CWE-36 vulnerability in mlflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mlflow — see the affected versions and patch details below.

Absolute Path Traversal in mlflow/mlflow

Also known asBIT-mlflow-2023-3765GHSA-fmxj-6h9g-6vw3PYSEC-2023-308
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-3765.

EPSS Exploitation Probability

via FIRST.org ↗
67.5%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
60.1%73.0%85.8%98.7%91.5%67.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mlflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Absolute Path Traversal in GitHub repository mlflow/mlflow prior to 2.5.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImlflowall versions2.5.0pip install --upgrade 'mlflow==2.5.0'

Affected Products

1 product · 1 configurations
Application
mlflowlfprojects
< 2.5.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mlflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mlflow to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-3765 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2023-3765

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-3765 -u https://target
Template
MLflow Absolute Path Traversal
Severity
critical
Impact
This vulnerability can lead to unauthorized access to sensitive information stored on the server.
Remediation
Upgrade to a patched version of MLflow to mitigate the Absolute Path Traversal vulnerability.

Template by ProjectDiscovery nuclei-templates (DhiyaneshDK), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Absolute Path Traversal in GitHub repository mlflow/mlflow prior to 2.5.0.
O3 Security · Impact-Aware SCA

Is CVE-2023-3765 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-3765: mlflow Path Traversal — Fixed in 2.5.0