NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2023-37365 — hnswlib

MEDIUMFix: nmslib/hnswlib#484

CVE-2023-37365 is a medium-severity (CVSS 6.5) CWE-415 vulnerability in hnswlib. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for hnswlib — see the affected versions and patch details below.

hnswlib Double Free vulnerability

Also known asGHSA-xwc8-rf6m-xr86PYSEC-2026-1450
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-37365.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.72%1.09%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍hnswlib

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Hnswlib 0.7.0 has a double free in init_index when the M argument is a large integer.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIhnswliball versions0.8.0pip install --upgrade 'hnswlib==0.8.0'

Affected Products

1 product · 1 configurations
Application
hnswlibhnswlib_project
1 version
0.7.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hnswlib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hnswlib to 0.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-37365 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

Hnswlib 0.7.0 has a double free in init_index when the M argument is a large integer.
O3 Security · Impact-Aware SCA

Is CVE-2023-37365 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-37365: hnswlib — Fixed in 0.8.0