NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-37298 — joplin

MEDIUMFix: laurent22/joplin@caf6606

CVE-2023-37298 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in joplin. A fix is available for joplin — see the affected versions and patch details below.

Joplin Cross-site Scripting vulnerability

Also known asGHSA-7grw-xfx6-qhx6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-37298.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.36%0.72%1.07%0.4%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
joplinnpm
3Kdownloads / week

Description

Joplin before 2.11.5 allows XSS via a USE element in an SVG document.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmjoplinall versions2.11.5npm install joplin@2.11.5

Affected Products

1 product · 1 configurations
Application
joplinjoplin_project
< 2.11.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for joplin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update joplin to 2.11.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-37298 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Joplin before 2.11.5 allows XSS via a USE element in an SVG document.
O3 Security · Impact-Aware SCA

Is CVE-2023-37298 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-37298: joplin XSS — Fixed in 2.11.5