NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-3692 — admidio

MEDIUMFix: admidio/admidio@d66585d

CVE-2023-3692 is a medium-severity (CVSS 6.7) Unrestricted File Upload vulnerability in admidio/admidio. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for admidio/admidio — see the affected versions and patch details below.

Unrestricted Upload of File with Dangerous Type in admidio/admidio

Also known asGHSA-q347-jrx8-5pw9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-3692.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.01%1.51%0.1%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘admidio/admidio

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Unrestricted Upload of File with Dangerous Type in GitHub repository admidio/admidio prior to 4.2.10.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistadmidio/admidioall versions4.2.10composer require admidio/admidio:^4.2.10

Affected Products

1 product · 1 configurations
Application
admidioadmidio
< 4.2.10
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for admidio/admidio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update admidio/admidio to 4.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-3692 is resolved across your whole dependency graph.

  3. Workarounds

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

Frequently Asked Questions

Unrestricted Upload of File with Dangerous Type in GitHub repository admidio/admidio prior to 4.2.10.
O3 Security · Impact-Aware SCA

Is CVE-2023-3692 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-3692: admidio — Fixed in 4.2.10