CVE-2023-36828 is a medium-severity (CVSS 5.5) Cross-site Scripting (XSS) vulnerability in statamic/cms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for statamic/cms — see the affected versions and patch details below.
Statamic's Antlers sanitizer cannot effectively sanitize malicious SVG
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-36828.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
statamic/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Antlers sanitizer cannot effectively sanitize malicious SVG
Summary
The SVG tag does not sanitize malicious SVG. Therefore, an attacker can exploit this vulnerability to perform XSS attacks using SVG, even when using the sanitize function.
Details
Regarding the previous discussion mentioned here, it has been identified that the default blacklist in the FilesFieldtypeController (located at this link) only blocks certain file extensions such as php, php3, php4, php5, and phtml. This allows a malicious user to upload a manipulated SVG file disguised as a social media icon, potentially triggering an XSS vulnerability.
PoC Screenshot

PoC
- Create new Global set, let's say "Settings"
- Create a "Grid" field in Blueprint (named: social), then add somefields Name (text), URL (text) and Icon (Assets) in the section Fields.
- When calling the social setting in the
_footer.antlers.html, remember to sanitize
{{ settings:social }}
<a href="{{ $url }}" class="ml-4" aria-label="{{ $name }}" rel="noopener">
{{ svg :src="icon" class="h-6 w-6 hover:text-hot-pink" | sanitize }}
</a>
{{ /settings:social }}
- Upload the malicious SVG image, here is the code:
<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg width="500" height="500" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
<text x="20" y="35">Statamic</text>
<foreignObject width="500" height="500">
<iframe xmlns="http://www.w3.org/1999/xhtml" src="javascript:confirm(document.cookie);" width="400" height="250"/>
</foreignObject>
</svg>
Impact
Since the social media icon is displayed in the footer layout, any user can view it, potentially leading to the execution of XSS.
Suggestions to Mitigate or Resolve the Issue:
Sanitize when outputing the svg. This vulnerability caused by unsanitized File::get() when retrieving the SVG, it is crucial to sanitize the SVG when outputting it. The issue can be found in the following file: https://github.com/statamic/cms/blob/f806b6b007ddcf066082eef175653c5beaa96d60/src/Tags/Svg.php#L36-L40.
It is highly recommended to implement proper sanitization measures to ensure the security of the SVG content. One effective approach is to utilize a reliable package, such as https://github.com/darylldoyle/svg-sanitizer ,which provides comprehensive SVG sanitization capabilities.
So the code becomes:
use enshrined\svgSanitize\Sanitizer;
if (File::exists($file)) {
$sanitizer = new Sanitizer();
$dirtySVG = File::get($file);
$svg = $sanitizer->sanitize($dirtySVG);
break;
}
Reference
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | statamic/cms | all versions | 4.10.0composer require statamic/cms:^4.10.0 |
Affected Products
statamicstatamicResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for statamic/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update statamic/cms to 4.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-36828 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-36828 in your dependencies?
Find it across Packagist, including transitive dependencies.