CVE-2023-34620 is a high-severity (CVSS 7.5) Out-of-bounds Write vulnerability in github.com/hjson/hjson-go/v4. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/hjson/hjson-go/v4 — see the affected versions and patch details below.
hjson stack exhaustion vulnerability
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-34620.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hjson/hjson-go/v4☕org.hjson:hjson🐘laktak/hjsonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go, Maven, Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered hjson through 3.0.0 allows attackers to cause a denial of service or other unspecified impacts via crafted objects that deeply nested structures.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hjson/hjson-go/v4 | all versions | 4.5.0go get github.com/hjson/hjson-go/v4@v4.5.0 |
| ☕Maven | org.hjson:hjson | all versions | 3.0.1org.hjson:hjson:3.0.1 |
| 🐘Packagist | laktak/hjson | all versions | 2.3.0composer require laktak/hjson:^2.3.0 |
Affected Products
hjsonhjson_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hjson/hjson-go/v4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hjson/hjson-go/v4 to 4.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-34620 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Frequently Asked Questions
Is CVE-2023-34620 in your dependencies?
Find it across Go, Maven, Packagist, including transitive dependencies.