NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2023-34602 — jeecg-boot-parent

HIGHFix: jeecgboot/jeecg-boot@dd7bf10

CVE-2023-34602 is a high-severity (CVSS 7.5) SQL Injection vulnerability in org.jeecgframework.boot:jeecg-boot-parent. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.jeecgframework.boot:jeecg-boot-parent — see the affected versions and patch details below.

JeecgBoot vulnerable to SQL injection in queryTableDictItemsByCode

Also known asGHSA-784x-7w88-w564
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-34602.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.80%1.20%0.4%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jeecgframework.boot:jeecg-boot-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

JeecgBoot up to v 3.5.1 was discovered to contain a SQL injection vulnerability via the component queryTableDictItemsByCode in method org.jeecg.modules.api.controller.SystemApiController.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jeecgframework.boot:jeecg-boot-parentall versions3.5.1org.jeecgframework.boot:jeecg-boot-parent:3.5.1

Affected Products

1 product · 1 configurations
Application
jeecgbootjeecg
≤ 3.5.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jeecgframework.boot:jeecg-boot-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jeecgframework.boot:jeecg-boot-parent to 3.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-34602 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

JeecgBoot up to v 3.5.1 was discovered to contain a SQL injection vulnerability via the component `queryTableDictItemsByCode` in method `org.jeecg.modules.api.controller.SystemApiController`.
O3 Security · Impact-Aware SCA

Is CVE-2023-34602 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-34602: jeecg-boot SQL Injection — Fixed in 3.5.1