CVE-2023-34468 is a high-severity (CVSS 8.8) Code Injection vulnerability in org.apache.nifi:nifi-dbcp-base. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.nifi:nifi-dbcp-base — see the affected versions and patch details below.
Apache NiFi: Potential Code Injection with Database Services using H2
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-34468.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.nifi:nifi-dbcp-base☕org.apache.nifi:nifi-hikari-dbcp-service☕org.apache.nifi:nifi-dbcp-service-narReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The DBCPConnectionPool and HikariCPConnectionPool Controller Services in Apache NiFi 0.0.2 through 1.21.0 allow an authenticated and authorized user to configure a Database URL with the H2 driver that enables custom code execution.
The resolution validates the Database URL and rejects H2 JDBC locations.
You are recommended to upgrade to version 1.22.0 or later which fixes this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.nifi:nifi-dbcp-base | ≥ 0.0.2&&< 1.22.0 | 1.22.0org.apache.nifi:nifi-dbcp-base:1.22.0 |
| ☕Maven | org.apache.nifi:nifi-hikari-dbcp-service | ≥ 0.0.2&&< 1.22.0 | 1.22.0org.apache.nifi:nifi-hikari-dbcp-service:1.22.0 |
| ☕Maven | org.apache.nifi:nifi-dbcp-service-nar | ≥ 0.0.2&&< 1.22.0 | 1.22.0org.apache.nifi:nifi-dbcp-service-nar:1.22.0 |
Affected Products
nifiapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi-dbcp-base, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.nifi:nifi-dbcp-base to 1.22.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-34468 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2023-34468 in your dependencies?
Find it across Maven, including transitive dependencies.