CVE-2023-34090 — decidim
HIGHCVE-2023-34090 is a high-severity (CVSS 7.5) Information Exposure vulnerability in decidim. A fix is available for decidim — see the affected versions and patch details below.
Decidim vulnerable to sensitive data disclosure
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-34090.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
decidim💎decidim-meetingsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Note: added the actual report as a comment.
Summary
Decidim, a platform for digital citizen participation, uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table).
Impact
This issue may lead to Sensitive Data Disclosure.
Patches
The problem was patched in v0.27.3.
Workarounds
Disable or unpublish all meetings components from your application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | decidim | ≥ 0.27.0&&< 0.27.3 | 0.27.3bundle update decidim --conservative |
| 💎RubyGems | decidim-meetings | ≥ 0.27.0&&< 0.27.3 | 0.27.3bundle update decidim-meetings --conservative |
Affected Products
decidimdecidimDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for decidim, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update decidim to 0.27.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-34090 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2023-34090 in your dependencies?
Find it across RubyGems, including transitive dependencies.