NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2023-34035 — spring-security-config

HIGHFix: spring-projects/spring-security-samples@4e3bec9

CVE-2023-34035 is a high-severity (CVSS 7.3) CWE-863 vulnerability in org.springframework.security:spring-security-config. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.springframework.security:spring-security-config — see the affected versions and patch details below.

Spring Security's authorization rules can be misconfigured when using multiple servlets

Also known asGHSA-4vpr-xfrp-cj64
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
3 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-34035.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%1.08%2.17%3.25%2.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.springframework.security:spring-security-config☕org.springframework.security:spring-security-config☕org.springframework.security:spring-security-config

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Spring Security versions 5.8 prior to 5.8.5, 6.0 prior to 6.0.5, and 6.1 prior to 6.1.2 could be susceptible to authorization rule misconfiguration if the application uses requestMatchers(String) and multiple servlets, one of them being Spring MVC’s DispatcherServlet. (DispatcherServlet is a Spring MVC component that maps HTTP endpoints to methods on @Controller-annotated classes.)

Specifically, an application is vulnerable when all of the following are true:

  • Spring MVC is on the classpath
  • Spring Security is securing more than one servlet in a single application (one of them being Spring MVC’s DispatcherServlet)
  • The application uses requestMatchers(String) to refer to endpoints that are not Spring MVC endpoints

An application is not vulnerable if any of the following is true:

  • The application does not have Spring MVC on the classpath
  • The application secures no servlets other than Spring MVC’s DispatcherServlet
  • The application uses requestMatchers(String) only for Spring MVC endpoints

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.security:spring-security-config≥ 5.8.0&&< 5.8.55.8.5org.springframework.security:spring-security-config:5.8.5
☕Mavenorg.springframework.security:spring-security-config≥ 6.0.0&&< 6.0.56.0.5org.springframework.security:spring-security-config:6.0.5
☕Mavenorg.springframework.security:spring-security-config≥ 6.1.0&&< 6.1.26.1.2org.springframework.security:spring-security-config:6.1.2

Affected Products

1 product · 3 configurations
Application
spring securityvmware
≥ 6.1.0 && < 6.1.2
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security:spring-security-config, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.security:spring-security-config to 5.8.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-34035 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Spring Security versions 5.8 prior to 5.8.5, 6.0 prior to 6.0.5, and 6.1 prior to 6.1.2 could be susceptible to authorization rule misconfiguration if the application uses requestMatchers(String) and multiple servlets, one of them being Spring MVC’s DispatcherServlet. (DispatcherServlet is a Spring MVC component that maps HTTP endpoints to methods on @Controller-annotated classes.) Specifically, an application is vulnerable when all of the following are true: * Spring MVC is on the classpath * Spring Security is securing more than one servlet in a single application (one of them being
O3 Security · Impact-Aware SCA

Is CVE-2023-34035 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-34035: spring-security-config — Fixed in 5.8.5