CVE-2023-33141 — Yarp.ReverseProxy
HIGHCVE-2023-33141 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in Yarp.ReverseProxy. A fix is available for Yarp.ReverseProxy — see the affected versions and patch details below.
YARP Denial of Service Vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-33141.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Yarp.ReverseProxy.NETYarp.ReverseProxyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A denial of service vulnerability exists in YARP.
Patches
If you're using YARP 1.x, you should update to NuGet package version 1.1.2. If you're using YARP 2.0.0, you should update to NuGet package version 2.0.1.
You can do so by updating the PackageReference in your .csproj file
<ItemGroup>
- <PackageReference Include="Yarp.ReverseProxy" Version="2.0.0" />
- <PackageReference Include="Yarp.Telemetry.Consumption" Version="2.0.0" />
+ <PackageReference Include="Yarp.ReverseProxy" Version="2.0.1" />
+ <PackageReference Include="Yarp.Telemetry.Consumption" Version="2.0.1" />
</ItemGroup>
or by selecting 2.0.1 in the NuGet UI inside Visual Studio (Manage NuGet Packages / Updates)
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Yarp.ReverseProxy | all versions | 1.1.2dotnet add package Yarp.ReverseProxy --version 1.1.2 |
| .NETNuGet | Yarp.ReverseProxy | ≥ 2.0.0&&< 2.0.1 | 2.0.1dotnet add package Yarp.ReverseProxy --version 2.0.1 |
Affected Products
yet another reverse proxymicrosoftDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Yarp.ReverseProxy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Yarp.ReverseProxy to 1.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-33141 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2023-33141 in your dependencies?
Find it across NuGet, including transitive dependencies.