CVE-2023-32986 is a high-severity (CVSS 8.8) CWE-732 vulnerability in io.jenkins.plugins:file-parameters. EPSS puts its 30-day exploitation probability at 60.7% (99th percentile). A fix is available for io.jenkins.plugins:file-parameters — see the affected versions and patch details below.
Jenkins File Parameter Plugin arbitrary file write vulnerability
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-32986.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.jenkins.plugins:file-parametersReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins File Parameter Plugin 285.v757c5b_67a_c25 and earlier does not restrict the name (and resulting uploaded file name) of Stashed File Parameters.
This allows attackers with Item/Configure permission to create or replace arbitrary files on the Jenkins controller file system with attacker-specified content.
File Parameter Plugin 285.287.v4b_7b_29d3469d restricts the name (and resulting uploaded file name) of Stashed File Parameters.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.jenkins.plugins:file-parameters | all versions | 285.287.v4bio.jenkins.plugins:file-parameters:285.287.v4b |
Affected Products
file parametersjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.jenkins.plugins:file-parameters, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.jenkins.plugins:file-parameters to 285.287.v4b or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-32986 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-32986 in your dependencies?
Find it across Maven, including transitive dependencies.