CVE-2023-32697 — sqlite-jdbc
HIGHCVE-2023-32697 is a high-severity (CVSS 8.8) Code Injection vulnerability in org.xerial:sqlite-jdbc. A fix is available for org.xerial:sqlite-jdbc — see the affected versions and patch details below.
Sqlite-jdbc vulnerable to remote code execution when JDBC url is attacker controlled
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-32697.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xerial:sqlite-jdbcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
SQLite JDBC is a library for accessing and creating SQLite database files in Java. Sqlite-jdbc addresses a remote code execution vulnerability via JDBC URL. This issue impacting versions 3.6.14.1 through 3.41.2.1 and has been fixed in version 3.41.2.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xerial:sqlite-jdbc | ≥ 3.6.14.1&&< 3.41.2.2 | 3.41.2.2org.xerial:sqlite-jdbc:3.41.2.2 |
Affected Products
sqlite jdbcsqlite_jdbc_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xerial:sqlite-jdbc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xerial:sqlite-jdbc to 3.41.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-32697 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2023-32697 in your dependencies?
Find it across Maven, including transitive dependencies.