CVE-2023-32693 — decidim
HIGHCVE-2023-32693 is a high-severity (CVSS 8.1) Cross-site Scripting (XSS) vulnerability in decidim. A fix is available for decidim — see the affected versions and patch details below.
Decidim Cross-site Scripting vulnerability in the external link redirections
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-32693.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
decidim💎decidim-core💎decidim-core💎decidimReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The external link feature is susceptible to cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in versions 0.27.3 and 0.26.7.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | decidim | ≥ 0.25.0&&< 0.26.7 | 0.26.7bundle update decidim --conservative |
| 💎RubyGems | decidim-core | ≥ 0.27.0&&< 0.27.3 | 0.27.3bundle update decidim-core --conservative |
| 💎RubyGems | decidim-core | ≥ 0.25.0&&< 0.26.7 | 0.26.7bundle update decidim-core --conservative |
| 💎RubyGems | decidim | ≥ 0.27.0&&< 0.27.3 | 0.27.3bundle update decidim --conservative |
Affected Products
decidimdecidimDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for decidim, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update decidim to 0.26.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-32693 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-32693 in your dependencies?
Find it across RubyGems, including transitive dependencies.