CVE-2023-32081 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in io.vertx:vertx-stomp. A fix is available for io.vertx:vertx-stomp — see the affected versions and patch details below.
Vert.x STOMP server process client frames that would not send initially a connect frame
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-32081.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.vertx:vertx-stomp☕io.vertx:vertx-stompReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Vert.x STOMP is a vert.x implementation of the STOMP specification that provides a STOMP server and client. From versions 3.1.0 until 3.9.16 and 4.0.0 until 4.4.2, a Vert.x STOMP server processes client STOMP frames without checking that the client send an initial CONNECT frame replied with a successful CONNECTED frame. The client can subscribe to a destination or publish message without prior authentication. Any Vert.x STOMP server configured with an authentication handler is impacted. The issue is patched in Vert.x 3.9.16 and 4.4.2. There are no trivial workarounds.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.vertx:vertx-stomp | ≥ 3.1.0&&< 3.9.16 | 3.9.16io.vertx:vertx-stomp:3.9.16 |
| ☕Maven | io.vertx:vertx-stomp | ≥ 4.0.0&&< 4.4.2 | 4.4.2io.vertx:vertx-stomp:4.4.2 |
Affected Products
vert.x stompeclipseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.vertx:vertx-stomp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.vertx:vertx-stomp to 3.9.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-32081 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-32081 in your dependencies?
Find it across Maven, including transitive dependencies.