CVE-2023-32065 — commerce
MEDIUMCVE-2023-32065 is a medium-severity (CVSS 5.8) CWE-284 vulnerability in oro/commerce. A fix is available for oro/commerce — see the affected versions and patch details below.
OroCommerce get-totals-for-checkout API endpoint returns unwanted data
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
oro/commerce🐘oro/commerce🐘oro/commerceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
OroCommerce is an open-source Business to Business Commerce application built with flexibility in mind. Detailed Order totals information may be received by Order ID. This issue is patched in version 5.0.11 and 5.1.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | oro/commerce | ≥ 4.2.0 | No fix |
| 🐘Packagist | oro/commerce | ≥ 5.0.0&&< 5.0.11 | 5.0.11composer require oro/commerce:^5.0.11 |
| 🐘Packagist | oro/commerce | ≥ 5.1.0&&< 5.1.1 | 5.1.1composer require oro/commerce:^5.1.1 |
Affected Products
orocommerceoroincDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oro/commerce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2023-32065; check the affected-versions list above or the advisory for the patched release of oro/commerce, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-32065 in your dependencies?
Find it across Packagist, including transitive dependencies.