CVE-2023-31134 is a medium-severity (CVSS 4.8) Open Redirect vulnerability in tauri. A fix is available for tauri — see the affected versions and patch details below.
Tauri Open Redirect Vulnerability Possibly Exposes IPC to External Sites
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-31134.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tauri🦀tauri🦀tauriReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The Tauri IPC is usually strictly isolated from external websites but the isolation can be bypassed by redirecting an existing Tauri window to an external website. This is either possible by an application implementing a feature for users to visit arbitrary websites or due to a bug allowing the open redirect1.
This allows the external website access to the IPC layer and therefore to all configured and exposed Tauri API endpoints and application specific implemented Tauri commands.
Patches
This issue has been patched in the latest release and was backported to all previous 1.x releases.
Workarounds
Prevent arbitrary input in redirect features. Only allow trusted websites access to the IPC.
References
The feature to enable this behavior in a more constrained way was introduced in the 1.3 release and documentation around this can be found in the documentation.
Footnotes
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | tauri | ≥ 1.0.0&&< 1.0.9 | 1.0.9cargo update -p tauri --precise 1.0.9 |
| 🦀crates.io | tauri | ≥ 1.1.0&&< 1.1.4 | 1.1.4cargo update -p tauri --precise 1.1.4 |
| 🦀crates.io | tauri | ≥ 1.2.0&&< 1.2.5 | 1.2.5cargo update -p tauri --precise 1.2.5 |
Affected Products
tauritauriDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tauri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tauri to 1.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-31134 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is CVE-2023-31134 in your dependencies?
Find it across crates.io, including transitive dependencies.