CVE-2023-30861 is a high-severity (CVSS 7.5) CWE-539 vulnerability in flask. A fix is available for flask — see the affected versions and patch details below.
Flask vulnerable to possible disclosure of permanent session cookie due to missing Vary: Cookie header
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-30861.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
flask🐍flaskReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Flask is a lightweight WSGI web application framework. When all of the following conditions are met, a response containing data intended for one client may be cached and subsequently sent by the proxy to other clients. If the proxy also caches Set-Cookie headers, it may send one client's session cookie to other clients. The severity depends on the application's use of the session and the proxy's behavior regarding cookies. The risk depends on all these conditions being met.
- The application must be hosted behind a caching proxy that does not strip cookies or ignore responses with cookies.
- The application sets
session.permanent = True - The application does not access or modify the session at any point during a request.
SESSION_REFRESH_EACH_REQUESTenabled (the default).- The application does not set a
Cache-Controlheader to indicate that a page is private or should not be cached.
This happens because vulnerable versions of Flask only set the Vary: Cookie header when the session is accessed or modified, not when it is refreshed (re-sent to update the expiration) without being accessed or modified. This issue has been fixed in versions 2.3.2 and 2.2.5.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | flask | ≥ 2.3.0&&< 2.3.2 | 2.3.2pip install --upgrade 'flask==2.3.2' |
| 🐍PyPI | flask | all versions | 2.2.5pip install --upgrade 'flask==2.2.5' |
Affected Products
flaskpalletsprojectsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flask, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update flask to 2.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-30861 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Ironic content for Red Hat OpenShift Container Platform 4.11 | python-flask-1:1.1.2-6.el8 | RHSA-2023:3541 |
| Ironic content for Red Hat OpenShift Container Platform 4.12 | python-flask-1:2.0.1-3.el9 | RHSA-2023:3545 |
| Ironic content for Red Hat OpenShift Container Platform 4.13 | python-flask-2:2.0.1-4.el9.2 | RHSA-2023:3536 |
| Red Hat Enterprise Linux 7 Extras | python-flask-1:0.10.1-7.el7_9 | RHSA-2023:3525 |
| Red Hat OpenStack Platform 16.1 | python-flask-1:1.0.2-8.el8ost | RHSA-2023:3446 |
| Red Hat OpenStack Platform 16.2 | python-flask-1:1.0.2-8.el8ost | RHSA-2023:3444 |
| Red Hat OpenStack Platform 17.0 | python-flask-1:1.1.2-6.el9ost | RHSA-2023:3440 |
| Red Hat Quay 3 | quay/quay-rhel8:v3.10.0-150 | RHSA-2023:7341 |
Frequently Asked Questions
Is CVE-2023-30861 in your dependencies?
Find it across PyPI, including transitive dependencies.