CVE-2023-29519 is a critical-severity (CVSS 9) CWE-74 vulnerability in org.xwiki.platform:xwiki-platform-attachment-ui. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-attachment-ui — see the affected versions and patch details below.
Code injection in org.xwiki.platform:xwiki-platform-attachment-ui
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-29519.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-attachment-ui☕org.xwiki.platform:xwiki-platform-attachment-ui☕org.xwiki.platform:xwiki-platform-attachment-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A registered user can perform remote code execution leading to privilege escalation by injecting the proper code in the "property" field of an attachment selector, as a gadget of their own dashboard. Note that the vulnerability does not impact comments of a wiki.
Patches
The vulnerability has been patched in XWiki 13.10.11, 14.4.8, 14.10.2, 15.0-rc-1.
Workarounds
The problem can be worked around by applying following changes directly in XWiki.AttachmentSelector page: https://github.com/xwiki/xwiki-platform/commit/5e8725b4272cd3e5be09d3ca84273be2da6869c1.
References
- https://jira.xwiki.org/browse/XWIKI-20364
- https://github.com/xwiki/xwiki-platform/commit/5e8725b4272cd3e5be09d3ca84273be2da6869c1
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-attachment-ui | ≥ 3.0-rc-1&&< 13.10.11 | 13.10.11org.xwiki.platform:xwiki-platform-attachment-ui:13.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-attachment-ui | ≥ 14.0-rc-1&&< 14.4.8 | 14.4.8org.xwiki.platform:xwiki-platform-attachment-ui:14.4.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-attachment-ui | ≥ 14.5&&< 14.10.2 | 14.10.2org.xwiki.platform:xwiki-platform-attachment-ui:14.10.2 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-attachment-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-attachment-ui to 13.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-29519 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2023-29519 in your dependencies?
Find it across Maven, including transitive dependencies.