CVE-2023-29517 — xwiki-platform-office-vie…
HIGHCVE-2023-29517 is a high-severity (CVSS 7.5) Information Exposure vulnerability in org.xwiki.platform:xwiki-platform-office-viewer. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-office-viewer — see the affected versions and patch details below.
Exposure of Sensitive Information to an Unauthorized Actor in org.xwiki.platform:xwiki-platform-office-viewer
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-29517.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-office-viewer☕org.xwiki.platform:xwiki-platform-office-viewer☕org.xwiki.platform:xwiki-platform-office-viewerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The office document viewer macro was allowing anyone to see any file content from the hosting server, provided that the office server was connected and depending on the permissions of the user running the servlet engine (e.g. tomcat) running XWiki. The same vulnerability also allowed to perform internal requests to resources from the hosting server.
Patches
The problem has been patched in XWiki 13.10.11, 14.10.1, 14.4.8, 15.0-rc-1.
Workarounds
It might be possible to workaround this vulnerability by running XWiki in a sandbox with a user with very low privileges on the machine, now to run a servlet engine the user will always need access to some files, so in any case this workaround won't protect all files to be accessed.
References
- Original jira ticket: https://jira.xwiki.org/browse/XWIKI-20447
- Jira ticket related to another exploit using same root cause: https://jira.xwiki.org/browse/XWIKI-20324
- Jira ticket related to the possibility to exploit the same vulnerability to perform internal requests: https://jira.xwiki.org/browse/XWIKI-20449
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-office-viewer | ≥ 2.5-milestone-2&&< 13.10.11 | 13.10.11org.xwiki.platform:xwiki-platform-office-viewer:13.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-office-viewer | ≥ 14.0-rc-1&&< 14.4.8 | 14.4.8org.xwiki.platform:xwiki-platform-office-viewer:14.4.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-office-viewer | ≥ 14.5&&< 14.10.1 | 14.10.1org.xwiki.platform:xwiki-platform-office-viewer:14.10.1 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-office-viewer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-office-viewer to 13.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-29517 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2023-29517 in your dependencies?
Find it across Maven, including transitive dependencies.