Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🛡️
Not in CISA KEV
HIGH severity

CVE-2023-2948 — openemr

HIGHFix: openemr/openemr@af1ecf7

CVE-2023-2948 is a high-severity (CVSS 8.3) Cross-site Scripting (XSS) vulnerability. 1 public exploit reference exists, so weaponization risk is real. A fix is available — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Generic in openemr/openemr

Published
Updated
Affected
1 product
Patched
See advisory
Exploits
1 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-2948.

EPSS Exploitation Probability

via FIRST.org ↗
96.7%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
80.7%87.1%93.6%100.0%84.4%96.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2023-2948 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 397,508 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.

Description

Cross-site Scripting (XSS) - Generic in GitHub repository openemr/openemr prior to 7.0.1.

Affected Products

1 product · 1 configurations
Application
openemropen-emr
< 7.0.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Vulnerability
  1. Detect

    Identify every host running the affected component and compare the installed build against the fixed version below — for source-built or distro-packaged software the version string, not a lockfile, is the source of truth (`dpkg -l`, `rpm -q`, or the binary's own `--version`).

  2. Fix

    Upgrade the affected component to the fixed release for CVE-2023-2948, or apply your distribution's backported patch — distro builds are often patched at an older version number, so check your vendor's advisory rather than the upstream version alone.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2023-2948

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-2948 -u https://target
Template
OpenEMR < 7.0.1 - Cross-Site Scripting
Severity
medium
Impact
Unauthenticated attackers can inject malicious JavaScript through the list_id parameter, potentially stealing user credentials or executing unauthorized actions in the context of other users.
Remediation
Upgrade to OpenEMR version 7.0.1 or later.

Template by ProjectDiscovery nuclei-templates (ritikchaddha, princechaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Cross-site Scripting (XSS) - Generic in GitHub repository openemr/openemr prior to 7.0.1.
O3 Security · Impact-Aware SCA

Is CVE-2023-2948 in your dependencies?

Find it across , including transitive dependencies.

CVE-2023-2948: openemr XSS (High 8.3)