NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-29295 — community-edition

MEDIUM

CVE-2023-29295 is a medium-severity (CVSS 4.3) CWE-863 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Insecure Direct Object Reference (IDOR) in Create Quote Function

Also known asGHSA-354h-fpmq-68v7
Published
Updated
Affected
6 pkgs
Patched
2 / 6
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-29295.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.38%0.77%1.15%0.1%0.6%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/project-community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass a minor functionality. Exploitation of this issue does not require user interaction.

Affected Packages

6 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.5-p1&&< 2.4.5-p32.4.5-p3composer require magento/community-edition:^2.4.5-p3
🐘Packagistmagento/community-edition≥ 2.4.4-p1&&< 2.4.4-p42.4.4-p4composer require magento/community-edition:^2.4.4-p4
🐘Packagistmagento/project-community-editionall versionsNo fix

Affected Products

2 products · 35 configurations
Application
commerceadobe
8 versions
2.3.72.4.02.4.12.4.22.4.32.4.42.4.52.4.6
Application
magentoadobe
3 versions
2.4.42.4.52.4.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2023-29295; check the affected-versions list above or the advisory for the patched release of magento/community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass a minor functionality. Exploitation of this issue does not require user interaction.
O3 Security · Impact-Aware SCA

Is CVE-2023-29295 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-29295: community-edition — Fixed in 2.4.5-p3