CVE-2023-28858 is a low-severity (CVSS 3.7) CWE-193 vulnerability in redis. A fix is available for redis — see the affected versions and patch details below.
redis-py Race Condition vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-28858.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
redis🐍redis🐍redisReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
redis-py before 4.5.3, as used in ChatGPT and other products, leaves a connection open after canceling an async Redis command at an inopportune time (in the case of a pipeline operation), and can send response data to the client of an unrelated request in an off-by-one manner. The fixed versions for this CVE Record are 4.3.6, 4.4.3, and 4.5.3, but are believed to be incomplete. CVE-2023-28859 has been assigned the issues caused by the incomplete fixes.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | redis | ≥ 4.4.0&&< 4.4.3 | 4.4.3pip install --upgrade 'redis==4.4.3' |
| 🐍PyPI | redis | ≥ 4.5.0&&< 4.5.3 | 4.5.3pip install --upgrade 'redis==4.5.3' |
| 🐍PyPI | redis | ≥ 4.2.0&&< 4.3.6 | 4.3.6pip install --upgrade 'redis==4.3.6' |
Affected Products
redis-pyredisDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for redis, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update redis to 4.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-28858 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-28858 in your dependencies?
Find it across PyPI, including transitive dependencies.