NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2023-28755 — uri

MEDIUM

CVE-2023-28755 is a medium-severity (CVSS 5.3) CWE-1333 vulnerability in uri. A fix is available for uri — see the affected versions and patch details below.

Ruby URI component ReDoS issue

Also known asGHSA-hv5j-3h9f-99c2
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-28755.

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%1.11%2.22%3.34%0.3%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
💎uri💎uri💎uri💎uri

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsuri≥ 0.12.0&&< 0.12.10.12.1bundle update uri --conservative
💎RubyGemsuri≥ 0.11.0&&< 0.11.10.11.1bundle update uri --conservative
💎RubyGemsuri≥ 0.10.1&&< 0.10.20.10.2bundle update uri --conservative
💎RubyGemsuriall versions0.10.0.1bundle update uri --conservative

Affected Products

3 products · 8 configurations
OS
debian linuxdebian
1 version
10.0
OS
fedorafedoraproject
3 versions
363738
Application
uriruby-lang
≤ 0.10.0
3 versions
0.10.10.11.00.12.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for uri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update uri to 0.12.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-28755 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 8ruby:2.7-8080020230427102918.63b34585RHSA-2023:3821
Red Hat Enterprise Linux 8ruby:2.5-8090020230627084142.b46abd14RHSA-2023:7025
Red Hat Enterprise Linux 8ruby:3.1-8090020240311122605.a75119d5RHSA-2024:1431
Red Hat Enterprise Linux 8ruby:3.0-8100020240522072634.489197e6RHSA-2024:3500
Red Hat Enterprise Linux 9ruby:3.1-9030020240320163942.9RHSA-2024:1576
Red Hat Enterprise Linux 9ruby-0:3.0.7-162.el9_4RHSA-2024:3838
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-ruby27-ruby-0:2.7.8-132.el7RHSA-2023:3291

Frequently Asked Questions

A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.
O3 Security · Impact-Aware SCA

Is CVE-2023-28755 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2023-28755: uri — Fixed in 0.12.1