NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2023-28609 — semaphore

CRITICALFix: ansible-semaphore/semaphore@3e4a62b

CVE-2023-28609 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in github.com/ansible-semaphore/semaphore. A fix is available for github.com/ansible-semaphore/semaphore — see the affected versions and patch details below.

Ansible Semaphore mishandles authentication

Also known asGHSA-pmhg-cmjc-3875
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-28609.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.37%0.4%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/ansible-semaphore/semaphore

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

api/auth.go in Ansible Semaphore before 2.8.89 mishandles authentication.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/ansible-semaphore/semaphoreall versions2.8.89go get github.com/ansible-semaphore/semaphore@v2.8.89

Affected Products

1 product · 1 configurations
Application
ansible semaphoreansible-semaphore
< 2.8.89
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/ansible-semaphore/semaphore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/ansible-semaphore/semaphore to 2.8.89 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-28609 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

api/auth.go in Ansible Semaphore before 2.8.89 mishandles authentication.
O3 Security · Impact-Aware SCA

Is CVE-2023-28609 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-28609: semaphore — Fixed in 2.8.89