CVE-2023-28333 is a critical-severity (CVSS 9.8) Code Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle: pix helper potential mustache code injection risk
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-28333.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The Mustache pix helper contained a potential Mustache injection risk if combined with user input (note: This did not appear to be implemented/exploitable anywhere in the core Moodle LMS).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 4.1.0&&< 4.1.2 | 4.1.2composer require moodle/moodle:^4.1.2 |
| 🐘Packagist | moodle/moodle | ≥ 4.0.0&&< 4.0.7 | 4.0.7composer require moodle/moodle:^4.0.7 |
| 🐘Packagist | moodle/moodle | ≥ 3.11.0&&< 3.11.13 | 3.11.13composer require moodle/moodle:^3.11.13 |
| 🐘Packagist | moodle/moodle | all versions | 3.9.20composer require moodle/moodle:^3.9.20 |
Affected Products
fedorafedoraprojectmoodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-28333 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2023-28333 in your dependencies?
Find it across Packagist, including transitive dependencies.