NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-27904 — jenkins-core

MEDIUMFix: jenkinsci/jenkins@4066358

CVE-2023-27904 is a medium-severity (CVSS 5.3) vulnerability in org.jenkins-ci.main:jenkins-core. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Information disclosure through error stack traces related to agents

Also known asBIT-jenkins-2023-27904GHSA-rrgp-c2w8-6vg6
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-27904.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.22%0.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins 2.393 and earlier, LTS 2.375.3 and earlier, and prior to LTS 2.387.1 prints an error stack trace on agent-related pages when agent connections are broken, potentially revealing information about Jenkins configuration that is otherwise inaccessible to attackers.

Jenkins 2.394, LTS 2.375.4, and LTS 2.387.1 does not display error stack traces when agent connections are broken.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 2.376&&< 2.387.12.387.1org.jenkins-ci.main:jenkins-core:2.387.1
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions2.375.4org.jenkins-ci.main:jenkins-core:2.375.4
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 2.388&&< 2.3942.394org.jenkins-ci.main:jenkins-core:2.394

Affected Products

1 product · 2 configurations
Application
jenkinsjenkins
< 2.394
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 2.387.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-27904 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

OpenShift 3.11 is already in the ELS support model phase. The Jenkins components are out of the scope of the ELS support; hence OpenShift 3.11 Jenkins component is marked in this CVE as Out of Support Scope.

ProductFixed inAdvisory
OCP-Tools-4.12-RHEL-8jenkins-0:2.387.1.1683009767-3.el8RHSA-2023:3195
OCP-Tools-4.12-RHEL-8jenkins-0:2.414.3.1698293911-3.el8RHSA-2023:6172
OCP-Tools-4.12-RHEL-8jenkins-0:2.426.3.1706515686-3.el8RHSA-2024:0778
OCP-Tools-4.13-RHEL-8jenkins-0:2.387.3.1684911776-3.el8RHSA-2023:3299
OCP-Tools-4.13-RHEL-8jenkins-0:2.401.1.1686680404-3.el8RHSA-2023:3622
OpenShift Developer Tools and Services for OCP 4.11jenkins-0:2.387.1.1683009763-3.el8RHSA-2023:3198
OpenShift Developer Tools and Services for OCP 4.11jenkins-0:2.401.1.1686831596-3.el8RHSA-2023:3663
OpenShift Developer Tools and Services for OCP 4.11jenkins-0:2.414.3.1698298955-3.el8RHSA-2023:6171

Frequently Asked Questions

Jenkins 2.393 and earlier, LTS 2.375.3 and earlier, and prior to LTS 2.387.1 prints an error stack trace on agent-related pages when agent connections are broken, potentially revealing information about Jenkins configuration that is otherwise inaccessible to attackers. Jenkins 2.394, LTS 2.375.4, and LTS 2.387.1 does not display error stack traces when agent connections are broken.
O3 Security · Impact-Aware SCA

Is CVE-2023-27904 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-27904: jenkins-core — Fixed in 2.387.1