CVE-2023-26474 — xwiki-platform-oldcore
CRITICALCVE-2023-26474 is a critical-severity (CVSS 9.9) CWE-284 vulnerability in org.xwiki.platform:xwiki-platform-oldcore. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-oldcore — see the affected versions and patch details below.
XWiki Platform vulnerable to privilege escalation via properties with wiki syntax that are executed with wrong author
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-26474.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-oldcore☕org.xwiki.platform:xwiki-platform-legacy-oldcore☕org.xwiki.platform:xwiki-platform-oldcore☕org.xwiki.platform:xwiki-platform-legacy-oldcore☕org.xwiki.platform:xwiki-platform-oldcore☕org.xwiki.platform:xwiki-platform-legacy-oldcoreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
It's possible to use the right of an existing document content author to execute a text area property.
To reproduce:
- As an admin with programming rights, create a new user without script or programming right.
- Login with the freshly created user.
- Insert the following text in source mode in the about section:
{{groovy}}println("hello from groovy!"){{/groovy}}
- Click "Save & View"
Patches
This has been patched in XWiki 14.10, 14.4.7, and 13.10.11.
Workarounds
No known workaround.
References
https://jira.xwiki.org/browse/XWIKI-20373
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira
- Email us at Security ML
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-oldcore | ≥ 13.10&&< 13.10.11 | 13.10.11org.xwiki.platform:xwiki-platform-oldcore:13.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-legacy-oldcore | ≥ 13.10&&< 13.10.11 | 13.10.11org.xwiki.platform:xwiki-platform-legacy-oldcore:13.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-oldcore | ≥ 14.0&&< 14.4.7 | 14.4.7org.xwiki.platform:xwiki-platform-oldcore:14.4.7 |
| ☕Maven | org.xwiki.platform:xwiki-platform-legacy-oldcore | ≥ 14.0&&< 14.4.7 | 14.4.7org.xwiki.platform:xwiki-platform-legacy-oldcore:14.4.7 |
| ☕Maven | org.xwiki.platform:xwiki-platform-oldcore | ≥ 14.5&&< 14.10 | 14.10org.xwiki.platform:xwiki-platform-oldcore:14.10 |
| ☕Maven | org.xwiki.platform:xwiki-platform-legacy-oldcore | ≥ 14.5&&< 14.10 | 14.10org.xwiki.platform:xwiki-platform-legacy-oldcore:14.10 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-oldcore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-oldcore to 13.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26474 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-26474 in your dependencies?
Find it across Maven, including transitive dependencies.