CVE-2023-26472 is a critical-severity (CVSS 9.9) CWE-116 vulnerability in org.xwiki.platform:xwiki-platform-icon-ui. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-icon-ui — see the affected versions and patch details below.
XWiki Platform vulnerable to privilege escalation via async macro and IconThemeSheet from the user profile
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-26472.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-icon-ui☕org.xwiki.platform:xwiki-platform-icon-ui☕org.xwiki.platform:xwiki-platform-icon-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
One can execute any wiki content with the right of IconThemeSheet author by creating an icon theme with the following content:
}}}
{{async async="true"}}
{{groovy}}
println("Hello from Groovy!")
{{/groovy}}
{{/async}}
{{{
Can be done by creating a new page or even through the user profile for users not having edit right.
Patches
This has been patched in XWiki 14.9, 14.4.6, and 13.10.10.
Workarounds
An easy workaround is to actually fix the bug in the page IconThemesCode.IconThemeSheet by applying the following modification: https://github.com/xwiki/xwiki-platform/commit/48caf7491595238af2b531026a614221d5d61f38#diff-2ec9d716673ee049937219cdb0a92e520f81da14ea84d144504b97ab2bdae243R45
References
https://jira.xwiki.org/browse/XWIKI-19731
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira
- Email us at Security ML
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-icon-ui | ≥ 6.2-milestone-1&&< 13.10.10 | 13.10.10org.xwiki.platform:xwiki-platform-icon-ui:13.10.10 |
| ☕Maven | org.xwiki.platform:xwiki-platform-icon-ui | ≥ 14.0&&< 14.4.6 | 14.4.6org.xwiki.platform:xwiki-platform-icon-ui:14.4.6 |
| ☕Maven | org.xwiki.platform:xwiki-platform-icon-ui | ≥ 14.5&&< 14.9 | 14.9org.xwiki.platform:xwiki-platform-icon-ui:14.9 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-icon-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-icon-ui to 13.10.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26472 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-26472 in your dependencies?
Find it across Maven, including transitive dependencies.