NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2023-26464 — log4j-core

HIGH

CVE-2023-26464 is a high-severity (CVSS 7.5) Deserialization of Untrusted Data vulnerability in org.apache.logging.log4j:log4j-core. A fix is available for org.apache.logging.log4j:log4j-core — see the affected versions and patch details below.

Apache Log4j 1.x (EOL) allows DoS in Chainsaw and SocketAppender

Also known asGHSA-vp98-w2p3-mv35
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-26464.

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.81%1.63%2.44%0.2%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.logging.log4j:log4j-core☕log4j:log4j

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

** UNSUPPORTED WHEN ASSIGNED **

When using the Chainsaw or SocketAppender components with Log4j 1.x on JRE less than 1.7, an attacker that manages to cause a logging entry involving a specially-crafted (ie, deeply nested) hashmap or hashtable (depending on which logging component is in use) to be processed could exhaust the available memory in the virtual machine and achieve Denial of Service when the object is deserialized.

This issue affects Apache Log4j before 2. Affected users are recommended to update to Log4j 2.x.

NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.logging.log4j:log4j-core≥ 1.0.4&&< 2.02.0org.apache.logging.log4j:log4j-core:2.0
☕Mavenlog4j:log4j≥ 1.0.4&&< 2.02.0log4j:log4j:2.0

Affected Products

1 product · 1 configurations
Application
log4japache
≥ 1.0.4 && < 2.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.logging.log4j:log4j-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.logging.log4j:log4j-core to 2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26464 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat Enterprise Linux 8 and 9 security impacts have been reduced to Low as they do not enable the vulnerable JDK by default.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2023-26464 (CC BY 4.0)
ProductFixed inAdvisory
OpenShift Developer Tools and Services for OCP 4.11jenkins-2-plugins-0:4.11.1686831822-1.el8RHSA-2023:3663
Red Hat JBoss Enterprise Application Platformorg.wildfly.core/wildfly-core-security:15.0.30.Final-redhat-00001RHSA-2023:5488
Red Hat JBoss Enterprise Application Platform 7.1 EUS for RHEL 7eap7-apache-cxf-0:3.1.16-3.SP1_redhat_00001.1.ep7.el7RHSA-2024:10208
Red Hat JBoss Enterprise Application Platform 7.3 EUS for RHEL 7eap7-apache-cxf-0:3.4.10-1.SP1_redhat_00001.1.el7eapRHSA-2024:10207
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8eap7-activemq-artemis-0:2.16.0-15.redhat_00049.1.el8eapRHSA-2023:5485
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9eap7-activemq-artemis-0:2.16.0-15.redhat_00049.1.el9eapRHSA-2023:5486
Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7eap7-activemq-artemis-0:2.16.0-15.redhat_00049.1.el7eapRHSA-2023:5484

Frequently Asked Questions

** UNSUPPORTED WHEN ASSIGNED ** When using the Chainsaw or SocketAppender components with Log4j 1.x on JRE less than 1.7, an attacker that manages to cause a logging entry involving a specially-crafted (ie, deeply nested) hashmap or hashtable (depending on which logging component is in use) to be processed could exhaust the available memory in the virtual machine and achieve Denial of Service when the object is deserialized. This issue affects Apache Log4j before 2. Affected users are recommended to update to Log4j 2.x. NOTE: This vulnerability only affects products that are no longer supp
O3 Security · Impact-Aware SCA

Is CVE-2023-26464 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-26464: log4j-core DoS — Fixed in 2.0