NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

CVE-2023-26303 — markdown-it-py

LOWFix: executablebooks/markdown-it-py@ae03c61

CVE-2023-26303 is a low-severity (CVSS 3.3) CWE-173 vulnerability in markdown-it-py. A fix is available for markdown-it-py — see the affected versions and patch details below.

markdown-it-py crash on null assertions

Also known asGHSA-vrjv-mxr7-vjf8PYSEC-2023-24
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-26303.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk-0.00%
Lower risk than most CVEs13th percentile — riskier than 13% of all scored CVEsHighest risk
0.00%0.24%0.48%0.73%0.1%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍markdown-it-py

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImarkdown-it-pyall versions2.2.0pip install --upgrade 'markdown-it-py==2.2.0'

Affected Products

1 product · 1 configurations
Application
markdown-it-pyexecutablebooks
< 2.2.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for markdown-it-py, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update markdown-it-py to 2.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26303 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
O3 Security · Impact-Aware SCA

Is CVE-2023-26303 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-26303: markdown-it-py DoS — Fixed in 2.2.0