NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-26115 — word-wrap

MEDIUMFix: jonschlinkert/word-wrap@420dce9

CVE-2023-26115 is a medium-severity (CVSS 5.3) CWE-1333 vulnerability in word-wrap. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for word-wrap — see the affected versions and patch details below.

word-wrap vulnerable to Regular Expression Denial of Service

Also known asGHSA-j8xg-fqg3-53r7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-26115.

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.74%1.48%2.21%0.0%1.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
word-wrapnpm
174.6Mdownloads / week

Description

All versions of the package word-wrap are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of an insecure regular expression within the result variable.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmword-wrapall versions1.2.4npm install word-wrap@1.2.4

Affected Products

1 product · 1 configurations
Application
word-wrapword-wrap_project
< 1.2.4
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for word-wrap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update word-wrap to 1.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26115 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
NETWORK-OBSERVABILITY-1.4.0-RHEL-9network-observability/network-observability-console-plugin-rhel9:v1.4.0-42RHSA-2023:5379
Red Hat Migration Toolkit for Containers 1.8rhmtc/openshift-migration-ui-rhel8:v1.8.0-7RHSA-2023:5447
Red Hat OpenShift Container Platform 4.14openshift4/ose-monitoring-plugin-rhel8:v4.14.0-202310201027.p0.g8757197.assembly.streamRHSA-2023:5006
Red Hat OpenShift Container Platform 4.14openshift4/nmstate-console-plugin-rhel8:v4.14.0-202312011333.p0.g8dc4a62.assembly.streamRHSA-2023:7681
Red Hat OpenShift GitOps 1.13openshift-gitops-1/console-plugin-rhel8:v1.13.2-4RHSA-2024:8581
Red Hat OpenShift GitOps 1.14openshift-gitops-1/console-plugin-rhel8:v1.14.0-16RHEA-2024:6787
Red Hat OpenShift GitOps 1.15openshift-gitops-1/console-plugin-rhel8:v1.15.0-15RHEA-2024:11005
RHODF-4.13-RHEL-9odf4/odf-console-rhel9:v4.13.3-1RHSA-2023:5376

Frequently Asked Questions

All versions of the package word-wrap are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of an insecure regular expression within the result variable.
O3 Security · Impact-Aware SCA

Is CVE-2023-26115 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-26115: word-wrap DoS — Fixed in 1.2.4