NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-26056 — xwiki-platform-rendering-…

MEDIUMFix: xwiki/xwiki-platform@4b75f21

CVE-2023-26056 is a medium-severity (CVSS 5.4) CWE-863 vulnerability in org.xwiki.platform:xwiki-platform-rendering-macro-context. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-rendering-macro-context — see the affected versions and patch details below.

XWiki Platform allows macro execution as any user without programming rights through the context macro

Also known asGHSA-859x-p6jp-rc2w
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-26056.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.xwiki.platform:xwiki-platform-rendering-macro-context☕org.xwiki.platform:xwiki-platform-rendering-macro-context☕org.xwiki.platform:xwiki-platform-rendering-macro-context

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

It's possible to execute a script with the right of another user (provided the target user does not have programming right).

For example, the following:

{{context document="xwiki:XWiki.userwithscriptright" transformationContext="document"}}{{velocity}}Hello from Velocity!{{/velocity}}{{/context}}

written by a user not having script right (for example in the user's profile) should produce an error (the user is not allowed to write scripts). However, because of the vulnerability, if the author of the document "xwiki:XWiki.userwithscriptright" has script right (but not programming right) the script will be executed with as if it was written by the target user.

Patches

The problem has been patched in XWiki 14.8RC1, 14.4.5 and 13.10.10.

Workarounds

There's no workaround for this issue.

References

https://jira.xwiki.org/browse/XWIKI-19856

For more information

If you have any questions or comments about this advisory:

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.xwiki.platform:xwiki-platform-rendering-macro-context≥ 3.0-milestone-1&&< 13.10.1013.10.10org.xwiki.platform:xwiki-platform-rendering-macro-context:13.10.10
☕Mavenorg.xwiki.platform:xwiki-platform-rendering-macro-context≥ 14.0-rc-1&&< 14.4.514.4.5org.xwiki.platform:xwiki-platform-rendering-macro-context:14.4.5
☕Mavenorg.xwiki.platform:xwiki-platform-rendering-macro-context≥ 14.5&&< 14.8-rc-114.8-rc-1org.xwiki.platform:xwiki-platform-rendering-macro-context:14.8-rc-1

Affected Products

1 product · 6 configurations
Application
xwikixwiki
≥ 14.5 && < 14.8
1 version
3.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-rendering-macro-context, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.xwiki.platform:xwiki-platform-rendering-macro-context to 13.10.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26056 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact It's possible to execute a script with the right of another user (provided the target user does not have programming right). For example, the following: ``` {{context document="xwiki:XWiki.userwithscriptright" transformationContext="document"}}{{velocity}}Hello from Velocity!{{/velocity}}{{/context}} ``` written by a user not having script right (for example in the user's profile) should produce an error (the user is not allowed to write scripts). However, because of the vulnerability, if the author of the document "xwiki:XWiki.userwithscriptright" has script right (but not prog
O3 Security · Impact-Aware SCA

Is CVE-2023-26056 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-26056: Fixed in 13.10.10 (Medium 5.4)