CVE-2023-25601 — Apache Dolphinscheduler
MEDIUMCVE-2023-25601 is a medium-severity (CVSS 4.3) Improper Authentication vulnerability in apache dolphinscheduler. A fix is available — see the affected versions and patch details below.
On version 3.0.0 through 3.1.1, Apache DolphinScheduler's python gateway suffered from improper authentication: an attacker could use a socket bytes attack without authentication. This…
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-25601.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Description
On version 3.0.0 through 3.1.1, Apache DolphinScheduler's python gateway suffered from improper authentication: an attacker could use a socket bytes attack without authentication. This issue has been fixed from version 3.1.2 onwards. For users who use version 3.0.0 to 3.1.1, you can turn off the python-gateway function by changing the value python-gateway.enabled=false in configuration file application.yaml. If you are using the python gateway, please upgrade to version 3.1.2 or above.
Affected Products
dolphinschedulerapacheDetection & mitigation playbook
Vendor / applianceDetect
Inventory every apache dolphinscheduler deployment and check each version against the affected-products list above.
Fix
Apply the apache dolphinscheduler security patch or hotfix for CVE-2023-25601 on the affected version, following the vendor advisory for your exact build.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used. Alongside that, restrict the management interface to trusted networks and apply the vendor's recommended configuration mitigations.
Frequently Asked Questions
Is CVE-2023-25601 being exploited in your environment?
Detect and block the exploit chain at execution, on systems you cannot patch yet.