NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-25569 — apollo

MEDIUMFix: apolloconfig/apollo@00d968a

CVE-2023-25569 is a medium-severity (CVSS 5.7) Cross-Site Request Forgery (CSRF) vulnerability in com.ctrip.framework.apollo:apollo. A fix is available for com.ctrip.framework.apollo:apollo — see the affected versions and patch details below.

apollo-portal has potential CSRF issue

Also known asGHSA-fmxq-v8mg-qh25
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs29th percentile — riskier than 29% of all scored CVEsHighest risk
0.00%0.28%0.57%0.85%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.ctrip.framework.apollo:apollo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A low-privileged user can create a special web page. If an authenticated portal admin visits this page, the page can silently send a request to assign new roles for that user without any confirmation from the Portal admin.

Patches

Cookie SameSite strategy was set to Lax in #4664 and was released in v2.1.0.

Workarounds

To fix the potential issue without upgrading, simply follow the advice that does not visit unknown source pages.

References

Apollo Security Guidence

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.ctrip.framework.apollo:apolloall versions2.1.0com.ctrip.framework.apollo:apollo:2.1.0

Affected Products

1 product · 1 configurations
Application
apolloapolloconfig
< 2.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.ctrip.framework.apollo:apollo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.ctrip.framework.apollo:apollo to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-25569 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact A low-privileged user can create a special web page. If an authenticated portal admin visits this page, the page can silently send a request to assign new roles for that user without any confirmation from the Portal admin. ### Patches Cookie SameSite strategy was set to Lax in #4664 and was released in [v2.1.0](https://github.com/apolloconfig/apollo/releases/tag/v2.1.0). ### Workarounds To fix the potential issue without upgrading, simply follow the advice that does not visit unknown source pages. ### References [Apollo Security Guidence](https://www.apolloconfig.com/#/en/usage/a
O3 Security · Impact-Aware SCA

Is CVE-2023-25569 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-25569: apollo — Fixed in 2.1.0