NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-23936 — undici

MEDIUMFix: nodejs/undici@a2eff05

CVE-2023-23936 is a medium-severity (CVSS 6.5) CWE-93 vulnerability in undici. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for undici — see the affected versions and patch details below.

CRLF Injection in Nodejs ‘undici’ via host

Also known asBIT-node-2023-23936BIT-node-min-2023-23936GHSA-5r9g-qh6m-jxff
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-23936.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.09%1.63%0.3%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

9Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
undicinpm
316.1Mdownloads / week

Description

Impact

undici library does not protect host HTTP header from CRLF injection vulnerabilities.

Patches

This issue was patched in Undici v5.19.1.

Workarounds

Sanitize the headers.host string before passing to undici.

References

Reported at https://hackerone.com/reports/1820955.

Credits

Thank you to Zhipeng Zhang (@timon8) for reporting this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmundici≥ 2.0.0&&< 5.19.15.19.1npm install undici@5.19.1

Affected Products

2 products · 4 configurations
Application
node.jsnodejs
≥ 19.0.0 && < 19.6.1
range
Application
undicinodejs
≥ 2.0.0 && < 5.19.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for undici, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update undici to 5.19.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-23936 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 8nodejs:16-8070020230314140722.bd1311edRHSA-2023:1582
Red Hat Enterprise Linux 8nodejs:18-8070020230322080930.bd1311edRHSA-2023:1583
Red Hat Enterprise Linux 9nodejs:18-9020020230327152102.rhel9RHSA-2023:2654
Red Hat Enterprise Linux 9nodejs-1:16.19.1-1.el9_2RHSA-2023:2655
Red Hat Enterprise Linux 9.0 Extended Update Supportnodejs-1:16.20.2-1.el9_0RHSA-2023:5533

Frequently Asked Questions

### Impact undici library does not protect `host` HTTP header from CRLF injection vulnerabilities. ### Patches This issue was patched in Undici v5.19.1. ### Workarounds Sanitize the `headers.host` string before passing to undici. ### References Reported at https://hackerone.com/reports/1820955. ### Credits Thank you to Zhipeng Zhang ([@timon8](https://hackerone.com/timon8)) for reporting this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2023-23936 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-23936: undici — Fixed in 5.19.1