CVE-2023-23926 is a medium-severity (CVSS 5.9) XML External Entity (XXE) vulnerability in org.neo4j.procedure:apoc-core. A fix is available for org.neo4j.procedure:apoc-core — see the affected versions and patch details below.
XML External Entity (XXE) vulnerability in apoc.import.graphml
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-23926.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.neo4j.procedure:apoc-core☕org.neo4j.procedure:apoc-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A XML External Entity (XXE) vulnerability found in the apoc.import.graphml procedure of APOC core plugin in Neo4j graph database. XML External Entity (XXE) injection occurs when the XML parser allows external entities to be resolved. The XML parser used by the apoc.import.graphml procedure was not configured in a secure way and therefore allowed this.
External entities can be used to read local files, send HTTP requests, and perform denial-of-service attacks on the application.
Abusing the XXE vulnerability enabled assessors to read local files remotely. Although with the level of privileges assessors had this was limited to one-line files. With the ability to write to the database, any file could have been read. Additionally, assessors noted, with local testing, the server could be crashed by passing in improperly formatted XML.
Patches
The users should aim to use the latest released version compatible with their Neo4j version. The minimum versions containing patch for this vulnerability is 5.5.0.
Workarounds
If you cannot upgrade the library, you can control the allowlist of the procedures that can be used in your system.
For more information
If you have any questions or comments about this advisory:
- Open an issue in neo4j-apoc
- Email us at [email protected]
Credits
We want to publicly recognise the contribution of Christopher Schneider – State Farm.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.neo4j.procedure:apoc-core | ≥ 5.0.0&&< 5.5.0 | 5.5.0org.neo4j.procedure:apoc-core:5.5.0 |
| ☕Maven | org.neo4j.procedure:apoc-core | all versions | 4.4.0.14org.neo4j.procedure:apoc-core:4.4.0.14 |
Affected Products
awesome procedures on cyperneo4jDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.neo4j.procedure:apoc-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.neo4j.procedure:apoc-core to 5.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-23926 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-23926 in your dependencies?
Find it across Maven, including transitive dependencies.