CVE-2023-23635 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in jellyfin-web. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for jellyfin-web — see the affected versions and patch details below.
Jellyfin Web Cross-Site Scripting (XSS) via Collection Name
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-23635.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
jellyfin-webnpmDescription
In Jellyfin 10.8.x through 10.8.3, the name of a collection is vulnerable to stored XSS. This allows an attacker to steal access tokens from the localStorage of the victim.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | jellyfin-web | ≥ 10.8.0&&< 10.8.4 | 10.8.4npm install jellyfin-web@10.8.4 |
Affected Products
jellyfinjellyfinResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jellyfin-web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update jellyfin-web to 10.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-23635 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-23635 in your dependencies?
Find it across npm, including transitive dependencies.