CVE-2023-22467 is a high-severity (CVSS 7.5) CWE-1333 vulnerability in luxon. A fix is available for luxon — see the affected versions and patch details below.
luxon.js inefficient regular expression complexity vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
luxonnpmDescription
Luxon is a library for working with dates and times in JavaScript. On the 1.x branch prior to 1.38.1, the 2.x branch prior to 2.5.2, and the 3.x branch on 3.2.1, Luxon's `DateTime.fromRFC2822() has quadratic (N^2) complexity on some specific inputs. This causes a noticeable slowdown for inputs with lengths above 10k characters. Users providing untrusted data to this method are therefore vulnerable to (Re)DoS attacks. This issue also appears in Moment as CVE-2022-31129. Versions 1.38.1, 2.5.2, and 3.2.1 contain patches for this issue. As a workaround, limit the length of the input.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | luxon | ≥ 1.0.0&&< 1.28.1 | 1.28.1npm install luxon@1.28.1 |
| 📦npm | luxon | ≥ 2.0.0&&< 2.5.2 | 2.5.2npm install luxon@2.5.2 |
| 📦npm | luxon | ≥ 3.0.0&&< 3.2.1 | 3.2.1npm install luxon@3.2.1 |
Affected Products
luxonmomentjsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for luxon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update luxon to 1.28.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-22467 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2023-22467 in your dependencies?
Find it across npm, including transitive dependencies.